Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • Need help?

    Create a topic in the appropriate section
    Don't write everything in the chat!
  • Take a look at the marketplace

    There you can buy
    everything related to game servers
  • Don't want a ban?

    Please read our rules
    Don't disturb the order!
  • Sell or buy?

    Use services of the guarantor
    We will make your deal safe
  • 0
VDT

Запуск клиента с командной строки

Приветствую. Появилась подобная задачка.

Сервер стартует с ключами - тут все понятно.

А вот клиент с подобными параметрами это делать отказывается.

Проблема в МОДах.

Он их видит, судя по куче иконок под кнопкой "играть" - даже загружает.

Но при попытке запустить игру, выдает ошибку отсутствия мода (каждый раз разный).

 

У кого-то получалось стартануть клиент с батника?

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Тема закрыта...

@echo off 
cls 

set version=1.0 
set wat=Dayz SA 

title %wat% Watchdog 

cd C:\Program Files (x86)\Steam\steamapps\common\DayZ

:watchdog 
echo (%time%) %wat% started. 
start "Dayz_SA" /wait "DayZ_BE.exe" "-mod=@CF;@Trader" -connect=ХХХ.XXX.XXX.XXX -port=XXXX
echo (%time%) %wat% closed or crashed, restarting. 
goto watchdog

Моды обязательно в корне 

Share this post


Link to post
Share on other sites



  • 0

изи dayz_be.exe -mod= и понеслось

если сервер ругается на моды, значит или список модов у вас не сходится на клиенте и сервере, или ключи не лежат от модов в keys сервера, или тупо 1 мод ломает остальные своим кривым кодом.

Share this post


Link to post
Share on other sites
  • 0
33 минуты назад, 123new сказал:

изи dayz_be.exe -mod= и понеслось

если сервер ругается на моды, значит или список модов у вас не сходится на клиенте и сервере, или ключи не лежат от модов в keys сервера, или тупо 1 мод ломает остальные своим кривым кодом.

Не изи... 

Список 1 в 1. Брал даже последовательность с сервера.

Если стартовать с лаунчера - все работает. Если с батника... нифига.

 

Еще раз отмечу, что тем самым моды он прогружает и в "лобби" их видит. Но подключать к серву таким образом отказывается.

Share this post


Link to post
Share on other sites
  • 0
5 часов назад, VDT сказал:

Не изи... 

Список 1 в 1. Брал даже последовательность с сервера.

Если стартовать с лаунчера - все работает. Если с батника... нифига.

 

Еще раз отмечу, что тем самым моды он прогружает и в "лобби" их видит. Но подключать к серву таким образом отказывается.

это называется руки из одного места)

Share this post


Link to post
Share on other sites
  • 0
1 час назад, 123new сказал:

это называется руки из одного места)

Тут даже спорить смысла нету )

Share this post


Link to post
Share on other sites
  • 0

@VDT Что значит - каждый раз разные - хз. Все ок стартует. Хотя половина модов за каким то хером используют пробелы в именах и т.п. бред.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site, you automaticly agree to our Guidelines and Privacy Policy.
We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.