Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • Need help?

    Create a topic in the appropriate section
    Don't write everything in the chat!
  • Take a look at the marketplace

    There you can buy
    everything related to game servers
  • Don't want a ban?

    Please read our rules
    Don't disturb the order!
  • Sell or buy?

    Use services of the guarantor
    We will make your deal safe
  • 0
Sign in to follow this  
Sett

Проблема с базой данных.

Не далее как вчера возникла проблемой с базой данных на сервере.
В начале игроки пожаловались на пропажу своего лута: у кого-то исчезли построенные ворота, у других бочки, шкафы и ящики с лутом.
Затем было замечено, что с сервера пропали все зомби и все животные, а так же прекратился спавн всего иного лута.

Был проведен вайп путем удаления папки data и backup. Это не помогло. 
Новые файлы в data были созданы игрой, а все подпапки backup остались девственно чистыми.

Для решения этой проблемы была удалена папка миссии сервера, сервер обновлен для скачивания этой миссии и в спавне появился лут, животные и зомби.
После остановки сервера, замены types.xml, init.c и messages.xml вновь был произведен вайп удалением всей папки storage_1. И снова в спавне нет животных, лута и зараженных. Остался редкий спавн камней и грибов.
types.xml был отредактирован на уменьшение количества спавна еды, медикаментов, оружия и патронов.
init.c - отредактирован на стартовый лут игроков.
messages.xml - дает рестарты.

Владелец сервера сказал, что при запуске и работе сервера не наблюдалось ошибок.
Где искать ошибку? Как ее исправить? 

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts










  • 0
1 час назад, guyfromgarlem сказал:

если ошибки в types.xml то не лута не зомби

Я проверил types.xml.
Мне выдало следующий результат
YWHP4A0MNkY.jpg
 

Share this post


Link to post
Share on other sites
  • 0

И правда была ошибка в types.xml
Спасибо за подсказку.

Share this post


Link to post
Share on other sites
  • 0
1 час назад, Sett сказал:

И правда была ошибка в types.xml
Спасибо за подсказку.

остальные проблемы от туда и шли

 

НАжми кнопулечку "Вопрос решен" 

Edited by guyfromgarlem (see edit history)

Share this post


Link to post
Share on other sites
  • 0
2 часа назад, guyfromgarlem сказал:

НАжми кнопулечку "Вопрос решен"

Не вижу ее.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you automaticly agree to our Guidelines and Privacy Policy.
We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.