Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • Need help?

    Create a topic in the appropriate section
    Don't write everything in the chat!
  • Take a look at the marketplace

    There you can buy
    everything related to game servers
  • Don't want a ban?

    Please read our rules
    Don't disturb the order!
  • Sell or buy?

    Use services of the guarantor
    We will make your deal safe
  • 0
hotaspid

Проблема с проверкой модов

Столкнулся с такой проблемой - при установке в файле config.cfg параметра verifySignatures = 3 сервер перестает пускать игроков, ссылаясь на один из установленных модов.

Если этот мод отключить, то ругается на следующий, если убрать и его то на другой и т.д.

Все ключи от модов установлены надлежащим образом, моды прописаны в батнике.

При параметре verifySignatures = 0 все работает без проблем, но это, как говорится, не вариант.

В чем может быть проблема?

Share this post


Link to post
Share on other sites

17 answers to this question

Recommended Posts










  • 0

А откуда там значение 3? Я чего-то не знаю?
https://community.bistudio.com/wiki/ArmA:_Addon_Signatures

Проверьте данный аддон прописанный в mission.sqm. Либо он там Не дописан, либо какой-то написан лишний. Вы точно уверены что клиенты совпадают?

Share this post


Link to post
Share on other sites
  • 0

TheFirstNoob mission.sqm :blink:

 

Ващет речь про DayZ SA

Ну и давно появились ключи версии 3 и verifySignatures = 3

У меня как не старался так и не вышло все поднять с работающей верификацией потому пока verifySignatures = 0

Но тк сервера под вайтлистами то как бы и не парюсь

 

Share this post


Link to post
Share on other sites
  • 0

BorizzK hotaspid , если папка scripts не распакована в папке сервера и не вынесена в корень, у каждого из модов имеется его ключ и подпись, ключи размещены где полагается, моды по списку и содержимому идентичны у сервера и клиента,  а у чисто серверных модов нет подписи и ключа (в т.ч. установленных), то при verifysignatures=2 и equalmodrequired=1; работает и проверка и вход на сервер на ура, проверено лично, сервера в таком формате уже более месяца работают.

Share this post


Link to post
Share on other sites
  • 0

123new Не вынесена не распакована -filepatching не используется

Только -mod и -servermod

 

Ругань на клиентах на моды итд итп

Так и не вышло ничего

Забили пока

Выйду из отпуска буду разбираться

 

123new Личку проверь - вопрос имеется

Share this post


Link to post
Share on other sites
  • 0

BorizzK значит или моды кривые попались, или делали чет не так)
ответил

Share this post


Link to post
Share on other sites
  • 0

123new Моды все та же общеизвестные - свои только servermod

До 1.04 все норм работало с подписями

Share this post


Link to post
Share on other sites
  • 0

BorizzK не спорю, но и с 1.04 работаю с модами и сервермодми, все пашет. Видимо чет не так с настройкой. Но выяснитьь это только вместе по удаленке можно.

Share this post


Link to post
Share on other sites
  • 0

123new я подключаюсь другой не подключается и так через раз

иной раз я не могу потом бац подключился

хз

забил пока

 

 

Share this post


Link to post
Share on other sites
  • 0

123new не бред а хз значет что

есть игроки которые подключаются всегда

есть которые через раз

и ругань на пбо хи

 

Share this post


Link to post
Share on other sites
  • 0

BorizzK ну так у меня все ок у всех, все нормально подключаются.
А не пробовал тех, у кого не подключается, попросить тупо отписаться от всех модов и подписаться с нуля заного на твои? По логике быть не должно такого, но зная стим, и такие чудеса могут проявиться.

Share this post


Link to post
Share on other sites
  • 0

BorizzK Блажен кто верует.....

Я как прикинул что все сервер моды слетят-наступает уныние и безнадёга. Даже хочеться пудовую свечку поставить.....

Share this post


Link to post
Share on other sites
  • 0

BorizzK так разверни уже щас на экспе 1.5 да проверь все, че уж ждать если криво в экспе криво и в стабилке будет.

Share this post


Link to post
Share on other sites
  • 0

DimitriPokki в экспе пока не удобно - я уже все на экспе гоняю но с распакованным scripts

Выйдет стабилка там и будем проверять

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site, you automaticly agree to our Guidelines and Privacy Policy.
We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.