Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • Need help?

    Create a topic in the appropriate section
    Don't write everything in the chat!
  • Take a look at the marketplace

    There you can buy
    everything related to game servers
  • Don't want a ban?

    Please read our rules
    Don't disturb the order!
  • Sell or buy?

    Use services of the guarantor
    We will make your deal safe
  • 0
11808_1487708102

Этот сервер работает на неправильной версии серверного приложения

Всем привет. Обновился так сказать с win 7 до win 10, решил запустить свой старенький дряхлый сервер dayz epoch overwatch, вроде бы всё сделал (Базу mysql и так далее настроил) запускаю сервер и в логах рпт начинается такая параша:

3:12:06 "HIVE: Starting"
13:12:06 "HIVE: trying to get objects"
13:12:06 Error in expression <ray = call compile format ["%1",_data];
_resultArray
};

server_hiveReadWriteLar>
13:12:06   Error position: <_resultArray
};

server_hiveReadWriteLar>
13:12:06   Error Undefined variable in expression: _resultarray
13:12:06 File z\addons\dayz_server\init\server_functions.sqf, line 191
13:12:06 Error in expression < select 1)) != "SCALAR")})) then {
if ((_hiveResponse select 1) == "Instance alr>
13:12:06   Error position: <_hiveResponse select 1) == "Instance alr>
13:12:06   Error Undefined variable in expression: _hiveresponse
13:12:06 File z\addons\dayz_server\system\server_monitor.sqf, line 43
13:12:06 "HIVE: trying to get objects"
13:12:06 "[Random_Weed_Farm]: Function loaded ... Server Building 3 Weed Farm(s)"
13:12:06 "[WEED_FARMS]: Found Location for a farm (116999) [11649.4,15382.4] with 2 plants"
13:12:06 "[WEED_FARMS]: Found Location for a farm (035008) [3561.45,14504.4] with 4 plants"
13:12:06 "[WEED_FARMS]: Found Location for a farm (123085) [12314.2,6760.34] with 3 plants"
13:12:06 "[WEED_FARMS]: Weed Farm(s) Done ... Broadcasting locations for clients"
13:12:06 Error in expression <ray = call compile format ["%1",_data];
_resultArray
};

 

Но это ещё пол беды. Начинается главная проблема о которой здесь писали многие из других старых тем, а именно: 

 

 

Делал уже всё что мог, то что описывали в данных темах, к сожалению не помогает. Господа, прошу вашей помощи т.к я уже в отчаянии :> Или всё же придется переходить обратно на семерку чтобы всё работало что не есть конечно хорошо. Заранее спасибо

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

Пробуйте еще раз. Проблема пакетов Visual C++, так же проверьте все ДЛЛ на сервере.tbbmalloc, database и т.п.
Приложите скриншот Панели управления с установленными пакетами.

Share this post


Link to post
Share on other sites









  • 0

Visual C++ все пакеты поставьте для начала.
х86 и х64 от 2005 года по 2017.
Сначала х86, потом х64. Ни в коем случае не наоборот.

Share this post


Link to post
Share on other sites
  • 0
4 минуты назад, TheFirstNoob сказал:

Visual C++ все пакеты поставьте для начала.
х86 и х64 от 2005 года по 2017.
Сначала х86, потом х64. Ни в коем случае не наоборот.

Дело в том что именно так и делал - результат нулевой.

Share this post


Link to post
Share on other sites
  • 0

Пример скриншота.
Так же переустановите пакеты NetFramework от 3.5. 4.0. 4.5+
 

Пожалуйста, Войдите или Зарегистрируйтесь, чтобы увидеть это: Вложение.

Share this post


Link to post
Share on other sites
  • 0
В 21.07.2019 в 17:50, TheFirstNoob сказал:

Пример скриншота.
Так же переустановите пакеты NetFramework от 3.5. 4.0. 4.5+
 

Пожалуйста, Войдите или Зарегистрируйтесь, чтобы увидеть это: Вложение.

Благодарю вас, к сожалению были трудности поставить 3.5 fraemwork, но VC++ поставил так как вы описали в скрине, всё заработало, если что за помощью можно к вам ещё обратится в ЛС? Данную тему можно закрывать.

Share this post


Link to post
Share on other sites
  • 0

11808_1487708102 Можно, при моем свободном времени и возможности вам помочь. На А2 я уже достаточно давно не сижу и помню многое чисто по памяти.
С NetFramework 3.5 скорее всего были трудности т.к. он входит в обязательный пакет установки самой винды, насколько помню.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site, you automaticly agree to our Guidelines and Privacy Policy.
We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.