Вопрос

Всем привет,хотелось бы узнать можно ли в арме 2 рендерить в текстуру?

Что то вроде этого _vehicle setObjectTexture [0, "#(argb,512,512,1)r2t(uavrtt,1)"]; как я понял это только на арме 3 работает.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

7 ответов на этот вопрос

KING324 в гугле забанили? или на богемию не зайти?

1 час назад, KING324 сказал:

как я понял это только на арме 3 работает.

https://yandex.ru/yandsearch?clid=740030&text=setObjectTexture&lr=2

https://community.bistudio.com/wiki/setObjectTexture

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Забронировать это рекламное место


1 минуту назад, NoNameUltima сказал:

про это я знаю,но это не совсем то что нужно. Нужно вывести на объект изображение с камеры

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
2 минуты назад, KING324 сказал:

про это я знаю,но это не совсем то что нужно. Нужно вывести на объект изображение с камеры

https://community.bistudio.com/wiki/Procedural_Textures

я не вижу чтоб там онли а3 упоминалась для р2т

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
2 минуты назад, NoNameUltima сказал:

https://community.bistudio.com/wiki/Procedural_Textures

я не вижу чтоб там онли а3 упоминалась для р2т

ну на а2 это не работает,по крайней мере у меня 

использовал этот код 

_vehicle = createVehicle ["WarfareBunkerSign", [7414.7217, 7841.3076, 0], [], 0, "CAN_COLLIDE"];
_vehicle setObjectTexture [0, "#(argb,512,512,1)r2t(rendersurface,1.333)"];
_vehicle setPos [7414.7217, 7841.3076, 0];
_vehicle setDir 127;

cam = "camera" camCreate [7454.7217, 7841.3076, 0];
cam cameraEffect ["Internal", "Back", "rendersurface"];

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

KING324 Что не работает то? Тебе ошибку выдает? Нет? Тогда с чего ты решил, что не работает? А ниче что селекшен не гарантированно представлен в моделях? см. Выше - пробуй для начала в Image на HUD вывести.

Изменено пользователем NoNameUltima (история изменений)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Цитата

KING324 Что не работает то? Тебе ошибку выдает? Нет? Тогда с чего ты решил, что не работает? А ниче что селекшен не гарантированно представлен в моделях? см. Выше - пробуй для начала в Image на HUD вывести.

просто картинку выводит на этот обьект,да и цвета ставятся,но при попытки вывести с камеры выдает ошибку текстура (#(argb,512,512,1)r2t(rendersurface,1.333)) не найдена 

Изменено пользователем KING324 (история изменений)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!


Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.


Войти сейчас