pekar0201

Векторная постройка, печальбеда...

Вопрос

Установил себе векторную постройку, после рестарта все постройки возвращаются на исходную позицию...
Precise base building стоит, как быть?????

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

16 ответов на этот вопрос

В fn_selfActions.sqf указал пути для файлов: player_upgrade.sqf и player_buildingDowngrade.sqf?

Изменено пользователем SkeepRyder (история изменений)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Забронировать это рекламное место


Установил себе векторную постройку, после рестарта все постройки возвращаются на исходную позицию...

Precise base building стоит, как быть?????

Криво установил, может? Логи об ошибках есть какие-то?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Криво установил, может? Логи об ошибках есть какие-то?

Ни логов, ничего, всё работает, но вот после рестарта не сохраняется...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ни логов, ничего, всё работает, но вот после рестарта не сохраняется...

Cлушай, а уверен, что возвращаются только постройки? Такая же проблема была, но вообще со всем и вся. Всё откатывало.

Пробовал переустановить скрипт? 

Как вариант, может косяк в двух файлах, что тебе кинули выше...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Cлушай, а уверен, что возвращаются только постройки? Такая же проблема была, но вообще со всем и вся. Всё откатывало.

Пробовал переустановить скрипт? 

Как вариант, может косяк в двух файлах, что тебе кинули выше...

Да всё со всем нормас, только постройки выёжываются!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Да всё со всем нормас, только постройки выёжываются!

Ещё как вариант не записываются данные в БД, либо не считываются после рестарта, что объект установлен под наклоном.

Вот так выглядит строка в БД: [25.755,[6617.018,7951.766,0.039],"ID - владельца",[[0.435,0.901,0],[-0.156,0.075,0.985]]]

У меня установлен P4L_v2.35 поэтому в середине строки добавляется ID-владельца. 

Проверь у себя в БД, поставь какой-нибудь объект и посмотри как запишутся его координаты, а после уже делать выводы и искать причину.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ещё как вариант не записываются данные в БД, либо не считываются после рестарта, что объект установлен под наклоном.

Вот так выглядит строка в БД: [25.755,[6617.018,7951.766,0.039],"ID - владельца",[[0.435,0.901,0],[-0.156,0.075,0.985]]]

У меня установлен P4L_v2.35 поэтому в середине строки добавляется ID-владельца. 

Проверь у себя в БД, поставь какой-нибудь объект и посмотри как запишутся его координаты, а после уже делать выводы и искать причину.

Как писались так и пишутся

Я уже хз что делать  :crying: 

Хелп!!!!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Как писались так и пишутся

Я уже хз что делать  :crying: 

Хелп!!!!

Вставь сюда строку из БД какого нибудь объекта(пол, стена, любого).

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вставь сюда строку из БД какого нибудь объекта(пол, стена, любого).

[222.098,[3586.66,8493.068,0.748],[[-0.67,-0.742,0],[0,0,1]]]

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

все что угодно может быть
надо в скрипте смотреть
кривая ли в бд запись
переменные какие то не передает
или именно после рестарта постройки съезжают

тут уже просто сидеть и ковырять,ставить в скрипте diag_log и если нужно,смотреть что происходит вообще

однозначно что то трудно сказать

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

все что угодно может быть

надо в скрипте смотреть

кривая ли в бд запись

переменные какие то не передает

или именно после рестарта постройки съезжают

 

тут уже просто сидеть и ковырять,ставить в скрипте diag_log и если нужно,смотреть что происходит вообще

однозначно что то трудно сказать

После рестарта..

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Да настолько сложная ситуация что-ли????
Ну наверняка-же у кого-то такое было!!!!!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Скачайте Vector Bulding с офф. форума и корректно установите.

4 раза переустанавливал!!!!

С офф форума, без толку!

Всё то-же самое....

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

4 раза переустанавливал!!!!

С офф форума, без толку!

Всё то-же самое....

Я гайд сделал как установить P4L+Snap_Pro+Vectors на уже собранный сервер, в понедельник могу скинуть(забыл на флешку скопировать на работе). Или же здесь гайд запелить.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!


Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.


Войти сейчас