Перейти к публикации
Поиск в
  • Дополнительно...
Искать результаты, содержащие...
Искать результаты в...

Продаёте или покупаете?

Пользуйтесь услугами гаранта
Мы сделаем вашу сделку безопасной

Вопрос

Добрый вечер, возникли проблемы при запуске 2 сервера на выделенной машине.

 

В общем у меня стоит 1 сервер напф, на порту 2302 и steamport =2302; steamqueryport =2300;

Все работает стабильно. Но как только я запускаю 2 сервер черно, при коннекте к серверу висит ожидание и справа в верхнем углу экрана, красным горит мой ник. в рпт спамит

Server error: Player without identity ewq (id 1704273621)

Пробовал меня порты не помогло. Логов от базы данных нет.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Рекомендованные сообщения

  • 0

Добрый вечер, возникли проблемы при запуске 2 сервера на выделенной машине.

 

В общем у меня стоит 1 сервер напф, на порту 2302 и steamport =2302; steamqueryport =2300;

Все работает стабильно. Но как только я запускаю 2 сервер черно, при коннекте к серверу висит ожидание и справа в верхнем углу экрана, красным горит мой ник. в рпт спамит

Server error: Player without identity ewq (id 1704273621)

Пробовал меня порты не помогло. Логов от базы данных нет.

Не в портах дело, ошибка сервера, нет индификации игрока по ID, ищи ошибки в серверной или миссии

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Забронировать это рекламное место


  • 0

Не в портах дело, ошибка сервера, нет индификации игрока по ID, ищи ошибки в серверной или миссии

Так дело в том что у меня на локалке он работает, но на хосте, где работает уже сервер напфа, запускаться как 2 сервер черно не хочет

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0

Так дело в том что у меня на локалке он работает, но на хосте, где работает уже сервер напфа, запускаться как 2 сервер черно не хочет

Ну полюбому где то косяк

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0

Так дело в том что у меня на локалке он работает, но на хосте, где работает уже сервер напфа, запускаться как 2 сервер черно не хочет

Могу конечно ошибаться, но предполагаю что на хостинге 1 IP и от этого сам хостинг не позволяет запустить.

т.е. сам хостинг так поставлен что ты можешь только 1 сервер пустить на нём.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0

ALEX39, да вот понятно, что где-то косяк. Хотелось бы понять где. Но то, что со сборкой все в порядке - это 100%.

 

EVGENIY1983, ip один. Это да. Но ты ж сам понимаешь, что на один ip можно ставить несколько игровых серверов. Со стороны хостинга ограничений нет никаких, так как у нас выделенный сервер, о чем в стартпосте написал KILOVAT. 

 

В общем, ситуация интересная и непонятная)) Пока найти корень зла не удается.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0

ALEX39, да вот понятно, что где-то косяк. Хотелось бы понять где. Но то, что со сборкой все в порядке - это 100%.

 

EVGENIY1983, ip один. Это да. Но ты ж сам понимаешь, что на один ip можно ставить несколько игровых серверов. Со стороны хостинга ограничений нет никаких, так как у нас выделенный сервер, о чем в стартпосте написал KILOVAT. 

 

В общем, ситуация интересная и непонятная)) Пока найти корень зла не удается.

Мало информации для обдумывания....Другую БД создал? Инстанс прописан в батнике другой? На какие порты менял? В конфиге прописано задание? Нового пользователя для БД создал,права выделил?

Изменено пользователем OMOH71 (история изменений)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0

Мало информации для обдумывания....Другую БД создал? Инстанс прописан в батнике другой? На какие порты менял? В конфиге прописано задание? Нового пользователя для БД создал,права выделил?

Это все создано, но вопрос, нужно 2 разных mysql подключений делать на разных портах? Или на одном достаточно?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0

Это все создано, но вопрос, нужно 2 разных mysql подключений делать на разных портах? Или на одном достаточно?

Одного достаточно,у меня с одним работало..

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0

Одного достаточно,у меня с одним работало..

а подключение одно делал? или 2? в navicat или еще где...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0
Проблема решена.


Решение данной проблемы:



1) Переименовать инстанции



2) Переименовать сервера, dayz_server, сделать 2 копии, 1 на сервер.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Присоединяйтесь к обсуждению

Вы можете опубликовать сообщение сейчас, а зарегистрироваться позже. Если у вас есть аккаунт, войдите в него для написания от своего имени.

Гость
Ответить на вопрос...

×   Вставлено в виде отформатированного текста.   Восстановить форматирование

  Разрешено не более 75 эмодзи.

×   Ваша ссылка была автоматически встроена.   Отобразить как ссылку

×   Ваш предыдущий контент был восстановлен.   Очистить редактор

×   Вы не можете вставить изображения напрямую. Загрузите или вставьте изображения по ссылке.

Загрузка...

  • Похожие публикации

    • Автор: lishuping
      Покупка серверов arma3 life altis для сборки,Запрашиваю полный набор, последний файл на сервере.
      vk:https://vk.com/id471630777  discor:Ezreal丶#9329
    • Автор: SPIRT
      Поделюсь еще одним рецептом )))))
      Имеем сервер Арма3 который запускаем для себя любимого и для друга, системник, кабель интернета и роутер или модем кому как нравится, так в чем проблема спросите, а вот в чем, если кабель инета подключен напрямую в системник то сервер виден в сетевой игре, а вот если подключаем интернет через модем то наш сервер пропадает из видимости. Бросаемся открывать порты, смотреть что не так, кароч глаза на лоб. Я тоже через все это прошел. Решилась проблема незатейливо включением на роутере функции DMZ или функции демилитаризованная зона. Расскажу на примере собственного роутера  ASUS. Собственно к делу :  Открываем в брузере настройки роутера, далее в левом меню нам нужна вкладка "Локальная сеть" 
      Пожалуйста, Войдите или Зарегистрируйтесь, чтобы увидеть это: Вложение.

      в открывшемся меню жмем на вкладку "DHCP сервер" в низу видим ----- "Список присвоенных вручную IP-адресов в обход DHCP (Максимум : 64)" ------ там еть пустое поле 
      MAC-адрес со стрелочкой, жмем на стрелку вылезает имя нашего компьтера и ip адрес  --- жмем "добавить"  на "+" с правой стороны ,в итоге получаем мак адрес нашей сетевой карты и присвоенный ip, жмем применить. 
      Идем далее ---  в левом меню выбираю вкладку интернет , в верхнем баре появляются разделы ..... ...... ..... "DMZ" Пожалуйста, Войдите или Зарегистрируйтесь, чтобы увидеть это: Вложение.
      жмем на нее  вылезает вкладка на ней 2 поля "Включить DMZ" и "IP-адрес выделенной станции", в первом жмем включить, во втором клацаем в пустое поле появляется IP адрес, или вбиваем в ручную тот который выпал рядом с мак адресом сетевой карты  ---- жмем применить . Обязательно перезагружаем модем.
       Далее запускаем свой сервак Арма и радуемся.
      Кому помогло + в репу.
    • Автор: Fockus
      В 0.60 патче DayZ Standalone есть такой баг, в браузере серверов идут большие лаги во время загрузки списка серверов. В этом гайде мы расскажем как вылечить этот недуг.
       
      Откройте стим, перейдите в настройки, далее найдите вкладку «В Игре» и найдите там раздел Внутриигрвой браузер серверов (по дефолту там стоит 5K серверов)
      Установите комфортное значение, и после этого у вас больше не должен лагать список серверов т.к не будет бешеной подгрузки всего списка.
       
    • Автор: StopS
      Сервер Arma 3 Exile + RHS не отображает моды в поиске серверов по поиску но через удаленный видит хорошо сервер.
      При заходе на сервер все работает нормально.

    • Автор: Yahweh
      Можно ли например запуская 2 сервера на одной машине, использовать разные @DayZ_Epoch_Server.
      Например @DayZ_Epoch_Server1 и @DayZ_Epoch_Server2 ?
×
×
  • Создать...