Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • Need help?

    Create a topic in the appropriate section
    Don't write everything in the chat!
  • Take a look at the marketplace

    There you can buy
    everything related to game servers
  • Don't want a ban?

    Please read our rules
    Don't disturb the order!
  • Sell or buy?

    Use services of the guarantor
    We will make your deal safe
  • 0
Heon

Ошибка подключенных модов

Доброго времени господа!

Сервер пиратка 1.17

Проблема в следушем при подключении некоторых модов таких как например @VPPAdminTools  или @UAZ452A выдает ошыбку на pbo (Не оброщайте внимания на мод снизу, он пишет так на большинство. Меняется только названия мода и путь до PBO)

 (В клиенте отсутствует мод, используемый на сервере. (Cl0ud's Military Gear)  (Отсутствует PBO. (@Cl0ud's Military Gear\addons\militarygear_backpacks.pbo)))

Мод имеется как и на сервере так и на клиенте ,Все обновлено и по нескольку раз(Сам сервер,клиент,моды.) (Так же бывает ошибка типо @UAZ452A (Отсутствует PBO. (  \dta\bin.pbo))

Про тесте на офф версии все работает,что не так с моей пираткой,вроде бы все файлы обновлены.

И кстати мод @VPPAdminTools выдает ошибку а @VPPAdminToolsFixed работает!

 

Share this post


Link to post
Share on other sites

18 answers to this question

Recommended Posts

  • 0

если все bikey и bisign в наличии, файлы идентичны, а ключи в нужном месте у сервера, то советую отключить все моды, добавлять по одному и искать виновника. Какой-то мод криво запакован тупо и все ломает.

Share this post


Link to post
Share on other sites







  • 0

Запустил с @CF и @admintools Ошибка (dta\bin.pbo менял и перекачивал)

 

(В клиенте отсутствует мод, используемый на сервере. (VPPAdminTools)  (Отсутствует PBO. (dta\bin.pbo)))


 

Заменил этот мод на @VPPAdminToolsFixed и добавил @UAZ452A 

 (В клиенте отсутствует мод, используемый на сервере. (UAZ452A)  (Отсутствует PBO. (dta\bin.pbo)))

Удалил все моды кроме @UAZ452A 

(В клиенте отсутствует мод, используемый на сервере. (UAZ452A)  (Отсутствует PBO. (dta\bin.pbo)))

 Ранее этот мод и все другие работали, я не понимаю что может быть не так, писал разработчику он сказал проблем с модом нету, да и на офф сервере он и другие запускаются нормально!

Share this post


Link to post
Share on other sites
  • 0
19 минут назад, Heon сказал:

Запустил с @CF и @admintools Ошибка (dta\bin.pbo менял и перекачивал)

 

(В клиенте отсутствует мод, используемый на сервере. (VPPAdminTools)  (Отсутствует PBO. (dta\bin.pbo)))


(В клиенте отсутствует мод, используемый на сервере. (VPPAdminTools)  (Отсутствует PBO. (dta\bin.pbo)))


 

Заменил этот мод на @VPPAdminToolsFixed и добавил @UAZ452A 

(В клиенте отсутствует мод, используемый на сервере. (UAZ452A) (Отсутствует PBO. (dta\bin.pbo)))


 (В клиенте отсутствует мод, используемый на сервере. (UAZ452A)  (Отсутствует PBO. (dta\bin.pbo)))

Удалил все моды кроме @UAZ452A 

(В клиенте отсутствует мод, используемый на сервере. (UAZ452A) (Отсутствует PBO. (dta\bin.pbo)))


(В клиенте отсутствует мод, используемый на сервере. (UAZ452A)  (Отсутствует PBO. (dta\bin.pbo)))

 Ранее этот мод и все другие работали, я не понимаю что может быть не так, писал разработчику он сказал проблем с модом нету, да и на офф сервере он и другие запускаются нормально!

переставь сервер с нуля и обнови все моды с воркшопа подчистую, есть подозрение что у тебя че-то криво обновлено или не обновлено. vpp админка с патчем 1.17 давно уже фиксилась

Share this post


Link to post
Share on other sites
  • 0

По идеи я все обновлял с варкшопа с нуля и сервер и клиент, попробую удалить дейзи с компа официальную и переустановить все, позже отпишу!

Share this post


Link to post
Share on other sites
  • 0

иногда обновлением и чистая установка с закачкой с нуля разнятся, сам стим кривит даже иногда.  Так что нет ничего лучше, чем выкачать все с нуля и собрать заного ;)

Share this post


Link to post
Share on other sites
  • 0

Сервер Обновлял, клиент тоже(Полное удаление и новая закачка). ошибка не меняется! Моды соответственно обновляються сами при полном удалении клиента и новой установке?

Share this post


Link to post
Share on other sites
  • 0

моды? нет конечно. Надо их ручками удалять все (папка workshop в папку игры скрытая + steamapps\workshop\content\221100) и перекачивать

 

Share this post


Link to post
Share on other sites
  • 0

Все чистил и удалял,закидывал по новой но ошибка не уходит

21:36:12 [CE][Hive] :: Initializing of spawners done.
21:36:12 [CE][Hive] :: Init sequence finished.
21:36:12 Player connect enabled
21:36:12 Задание загружено.
21:36:12 Connected to Steam
21:36:12 Steam policy response
21:36:12 Heon использует измененный файл данных
21:36:12 [Login]: Adding player Heon (59881500) to login queue at position 0
21:36:12 [LoginMachine]: Add player Heon (59881500 192.168.31.179:2304)
21:36:12 [StateMachine]: Player Heon (dpnid 59881500 uid ) Entering AuthPlayerLoginState
21:36:13 [IdleMode] Entering IN - save processed
21:36:13 [StateMachine]: Player Heon (dpnid 59881500 uid ) State Error (AuthPlayerLoginState)
21:36:13 Player Unknown (59881500) kicked from server: 116 (Клиент использует мод, которого нет на сервере. (@UAZ452A)  (Клиентский PBO не является частью сервера. (dta\bin.pbo)))
21:36:13 [StateMachine]: Kick player Heon (dpnid 59881500 uid ) State AuthPlayerLoginState
21:36:13 [Disconnect]: Client 59881500 early disconnect
21:36:13 [Disconnect]: No identity -> remove player info 59881500 
21:36:13 [Disconnect]: DisconnectPlayerFinish 59881500
21:36:13 [Disconnect]: Remove player info 59881500
21:36:13 [Disconnect]: Player destroy 59881500 
21:36:13 Игрок Heon отсоединился.

Смушают эти строки 

21:36:12 Connected to Steam
21:36:12 Steam policy response

Что то не так а что понять не могу!

Запуск клиента 

[Launcher]
Target = DayZ_x64.exe
StartIn = C:\Games\DayZ
CommandLine = -connect=192.168.31.179:2314 BEpath=C:\DayZServer\battleye -name=Heon "-mod=OsirisMod\@UAZ452A"
SteamClientPath = SmartSteamEmu\SmartSteamEmu.dll
SteamClientPath64 = SmartSteamEmu\SmartSteamEmu64.dll
Persist = 0
ParanoidMode = 0
InjectDll = 0

[SmartSteamEmu]
AvatarFilename = avatar.png
PersonaName = Heon
AppId = 221100
SteamIdGeneration = GenerateRandom
Language = English

VR = False
Offline = False
QuickJoinHotkey = SHIFT + TAB
MasterServer = 188.40.40.201:27010
MasterServerGoldSrc = 188.40.40.201:27010
[Achievements]
FailOnNonExistenceStats = False

[SSEOverlay]
DisableOverlay = True
OnlineMode = True
Language = 
ScreenshotHotkey = F12
HookRefCount = True
OnlineKey = 

[DirectPatch]

[Debug]
EnableLog = False
MarkLogHotkey = CTRL + ALT + M
LogFilter = User Logged On
Minidump = False

[DLC]
Default = True

[Networking]
BroadcastAddress = 192.168.0.1
ListenPort = 31313
MaximumPort = 10
DiscoveryInterval = 3
MaximumConnection = 200

[PlayerManagement]
AllowAnyoneConnect = False
AdminPassword = 

Запуск сервера 

[Launcher]
Target = DayZServer_x64
StartIn = C:\DayZServer
CommandLine = -port=2314 -BEpath=C:\DayZServer\battleye "-mod="@CF;@UAZ452A" "-servermod=" -config=serverDZ.cfg -cfg=profiles\basic.cfg -profiles=profiles -user=profiles -doLogs -enableHT -autoinit -loadMissionToMemory -adminlog -freezecheck -noFilePatching
SteamClientPath = SmartSteamEmu\SmartSteamEmu.dll
SteamClientPath64 = SmartSteamEmu\SmartSteamEmu64.dll
Persist = 0
ParanoidMode = 0
InjectDll = 0

[SmartSteamEmu]
AvatarFilename = avatar.png
PersonaName = Tester
AppId = 221100
SteamIdGeneration = GenerateRandom
Language = English

VR = False
Offline = False
QuickJoinHotkey = SHIFT + TAB
MasterServer = 188.40.40.201:27010
MasterServerGoldSrc = 188.40.40.201:27010
[Achievements]
FailOnNonExistenceStats = False

[SSEOverlay]
DisableOverlay = True
OnlineMode = True
Language = 
ScreenshotHotkey = F12
HookRefCount = True
OnlineKey = 

[DirectPatch]

[Debug]
EnableLog = False
MarkLogHotkey = CTRL + ALT + M
LogFilter = User Logged On
Minidump = False

[DLC]
Default = True

[Networking]
BroadcastAddress = 192.168.0.1
ListenPort = 31313
MaximumPort = 10
DiscoveryInterval = 3
MaximumConnection = 200

[PlayerManagement]
AllowAnyoneConnect = False
AdminPassword = 

Может в bat. файлах что то не так?

Edited by Heon (see edit history)

Share this post


Link to post
Share on other sites
  • 0

А ничего, что у вас на клиенте используется только OsirisMod\@UAZ452A а на сервере 2 мода @CF;@UAZ452A ? Ну как бы банально сравнить?

И еще, на клиенте BEpath смысла указывать мало.

 

Share this post


Link to post
Share on other sites
  • 0

@CF был вставлен уже после, так как где то читал что большинство модов используют @CF.Вот и решил добавить и запустить,но выше где ошибка там используется мод только @UAZ452A и сервер и клиент!

Share this post


Link to post
Share on other sites
  • 0

bikey от модов лежат в keys корневой сервера?

имена папок модов прописываемых, включая вкладываемые, символ в символ сходятся?

 

Если все так, то проблему надо смотреть, что называется, 'по факту на месте', т.к. что там у тебя происходит гадать сложно, а так хоть потестить можно. Учитывая, что это все время - проблематично.

Edited by 123new (see edit history)

Share this post


Link to post
Share on other sites
  • 0

bikey все как положено, названия модов тоже, может через радмин подключитесь посмотрите?

Share this post


Link to post
Share on other sites
  • 0

может, но не ранее, чем после 19:00 мск, т.к. не дома, и возможно за оплату в зависимости от потраченного времени.

 

Share this post


Link to post
Share on other sites
  • 0

а цена будет зависеть от потраченного времени, условно 500 за час

Share this post


Link to post
Share on other sites
  • 0

Дороговато,но я вас услышал если сам не решу проблему,то обязательно свяжусь с вами!

как найду ответ опишусь!

 

Вопрос не решён

Share this post


Link to post
Share on other sites
  • 0

Вообщем указал моды на сервер на примую к Workshop

"-Mod=C:\Program Files (x86)\Steam\steamapps\common\DayZ\!Workshop\@CF"

Сервер запускается абсолютно со всеми модами, но если указать в папке сервера и клиента

"-Mod=@CF"

 то выдают такую же ошибку как и вышес про pbo

Есть у кого какие нибудь предположения по поводу происходящего?

Share this post


Link to post
Share on other sites
  • 0

ну как уже и сказал, где-то или разница в файлах, или в именах папок. Когда ты путь полный не указываешь - он берется относительно корневой папки игры или сервера, когда указываешь - с указанного пути.

Сразу обращаю внимание, что указывать моды одновременно клиенту и серверу на рабочую папку стим воркшопа не лучшая идея, т.к. в случае если клиент закрыт, а сервер работает, и запущен стим - стим будет пытаться обновлять мод, но не сможет т.к. файлы задействованы сервером.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site, you automaticly agree to our Guidelines and Privacy Policy.
We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.